bayo
Posts: 32
Joined: Mon Dec 11, 2017 2:38 pm

Screen tearing

Sat Feb 10, 2018 5:04 pm

Hi,

Today noticed screen tearing while playing local files and youtube when the videos have fast movements.

Code: Select all

inxi -Fx
System:    Host: linux Kernel: 4.14.18-51.current x86_64 bits: 64 gcc: 7.3.0
           Desktop: Budgie 10.4  Distro: Solus 3
Machine:   Device: laptop System: Micro-Star product: GP72 2QE v: REV:1.0 serial: N/A
           Mobo: Micro-Star model: MS-1793 v: REV:0.B serial: N/A
           UEFI [Legacy]: American Megatrends v: E1793IMS.10D date: 09/23/2015
Battery    BAT1: charge: 36.8 Wh 91.3% condition: 40.4/42.4 Wh (95%)
           model: MSI BIF0_9 status: N/A
CPU:       Quad core Intel Core i7-5700HQ (-HT-MCP-) 
           arch: Broadwell rev.1 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 21550
           clock speeds: max: 3500 MHz 1: 1432 MHz 2: 1593 MHz 3: 2580 MHz
           4: 1235 MHz 5: 1220 MHz 6: 2048 MHz 7: 2036 MHz 8: 2213 MHz
Graphics:  Card-1: Intel HD Graphics 5600 bus-ID: 00:02.0
           Card-2: NVIDIA GM107M [GeForce GTX 950M] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,nvidia
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GTX 950M/PCIe/SSE2
           version: 4.5.0 NVIDIA 390.25 Direct Render: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Card-3 Corsair driver: USB Audio usb-ID: 001-009
           Card-4 Logitech C922 Pro Stream Webcam
           driver: USB Audio usb-ID: 003-004
           Sound: Advanced Linux Sound Architecture v: k4.14.18-51.current
Network:   Card-1: Intel Wireless 3160 driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: down mac: e4:f8:9c:6d:ac:d1
           Card-2: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx port: 3000 bus-ID: 04:00.0
           IF: enp4s0 state: up speed: 1000 Mbps duplex: full
           mac: d8:cb:8a:7f:af:5e
Drives:    HDD Total Size: 2000.4GB (39.3% used)
           ID-1: /dev/sda model: HGST_HTS721010A9 size: 1000.2GB
           ID-2: USB /dev/sdb model: SNA size: 1000.2GB
Partition: ID-1: / size: 476G used: 13G (3%) fs: ext4 dev: /dev/sdb4
           ID-2: swap-1 size: 8.86GB used: 0.00GB (0%)
           fs: swap dev: /dev/sdb2
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 230 Uptime: 58 min Memory: 3287.4/15960.4MB
           Init: systemd Gcc sys: N/A Client: Shell (bash 4.4.01) inxi: 2.3.38 
Thanks!

Code: Select all

Laptop System: MSI GP72 2QE
UEFI [Legacy]
Quad core Intel Core i7-5700HQ
Graphics:  Card-1: Intel HD Graphics 5600
Card-2: NVIDIA GM107M [GeForce GTX 950M]
OpenGL: renderer: Mesa DRI Intel HD Graphics 5600 (Broadwell GT2)

aiwan
Posts: 8
Joined: Mon Feb 12, 2018 6:48 pm

Re: Screen tearing

Mon Feb 12, 2018 6:54 pm

I think this is quite common problem, not solved as far as I know. I have the very same issue.

Some references about it that I found:
viewtopic.php?f=17&t=2781
https://dev.solus-project.com/T2267

Hope it gets some attention sooner than later, don't like using Chrome.

bayo
Posts: 32
Joined: Mon Dec 11, 2017 2:38 pm

Re: Screen tearing

Mon Feb 12, 2018 10:20 pm

aiwan wrote:
Mon Feb 12, 2018 6:54 pm
I think this is quite common problem, not solved as far as I know. I have the very same issue.

Some references about it that I found:
viewtopic.php?f=17&t=2781
https://dev.solus-project.com/T2267

Hope it gets some attention sooner than later, don't like using Chrome.
I removed the nvidia driver and now on Intell HD card no tearing on youtube and local files - except when i use "GNOME MPV" on local files but with "VLC 3" it is OK.

Code: Select all

Laptop System: MSI GP72 2QE
UEFI [Legacy]
Quad core Intel Core i7-5700HQ
Graphics:  Card-1: Intel HD Graphics 5600
Card-2: NVIDIA GM107M [GeForce GTX 950M]
OpenGL: renderer: Mesa DRI Intel HD Graphics 5600 (Broadwell GT2)

bwat47
Posts: 12
Joined: Sat Apr 08, 2017 12:35 pm

Re: Screen tearing

Tue Feb 13, 2018 1:59 pm

bayo wrote:
Mon Feb 12, 2018 10:20 pm
aiwan wrote:
Mon Feb 12, 2018 6:54 pm
I think this is quite common problem, not solved as far as I know. I have the very same issue.

Some references about it that I found:
viewtopic.php?f=17&t=2781
https://dev.solus-project.com/T2267

Hope it gets some attention sooner than later, don't like using Chrome.
I removed the nvidia driver and now on Intell HD card no tearing on youtube and local files - except when i use "GNOME MPV" on local files but with "VLC 3" it is OK.
For gnome-mpv disable the csd decorations in the preferences and that should fix the tearing: https://github.com/gnome-mpv/gnome-mpv/issues/232

Return to “Multimedia”