chdslv
Posts: 81
Joined: Fri Aug 08, 2014 5:54 am

[SOLVED]Gimp doesn't start in Solus 3

Wed Aug 16, 2017 12:00 pm

Gimp doesn't start in Solus 3
chdslv@chdslv ~ $ gimp
gimp: error while loading shared libraries: /usr/lib64/libgegl-0.2.so.0: file too short
Installed through Software Center.
No idea of the meaning file too short.

Reinstalled through terminal with same result.
chdslv@chdslv ~ $ sudo eopkg it gimp
Total size of package(s): 11.39 MB
Downloading 1 / 1
Package gimp found in repository Solus
gimp-2.8.22-25-1-x86_64.eopkg (11.4 MB)100% 3.65 MB/s [00:00:00] [complete]
Installing 1 / 1
gimp-2.8.22-25-1-x86_64.eopkg [cached]
Installing gimp, version 2.8.22, release 25
Extracting the files of gimp
Configuring gimp package
Configured gimp
Installed gimp
chdslv@chdslv ~ $ gimp
gimp: error while loading shared libraries: /usr/lib64/libgegl-0.2.so.0: file too short
Last edited by chdslv on Wed Aug 16, 2017 6:32 pm, edited 1 time in total.

TimApple
Posts: 13
Joined: Mon Mar 27, 2017 2:05 am
Contact: Website Twitter

Re: Gimp doesn't start in Solus 3

Wed Aug 16, 2017 12:10 pm

Did you do a fresh install for Solus 3? I just installed gimp and it is working on my system. But I did a fresh install on of new release.

antechdesigns
Posts: 257
Joined: Mon Jul 31, 2017 6:12 pm
Location: UK
Contact: Website

Re: Gimp doesn't start in Solus 3

Wed Aug 16, 2017 12:26 pm

Whats the output of:

Code: Select all

ls /usr/lib64/libgegl*
Please Follow me on vidme: Solus Tutorials: https://vid.me/antechdesigns

Follow me on youtube: Solus Tutorials: https://www.youtube.com/channel/UCi4qFG ... YFA/videos

chdslv
Posts: 81
Joined: Fri Aug 08, 2014 5:54 am

Re: Gimp doesn't start in Solus 3

Wed Aug 16, 2017 12:37 pm

antechdesigns wrote:
Wed Aug 16, 2017 12:26 pm
Whats the output of:

Code: Select all

ls /usr/lib64/libgegl*
I am now in another Linux distro where Gimp is working. I looked in the Solus install from that distro. The following two files are there, libgegl-0.2.so.0 ( a symlink) and libgegl-0.2.so.0.199.1
Both have nothing inside them, 0 bytes.

This points to another question, how to install libgegl-0.2? From where can it be to downloaded?

In Ubuntu there is libgegl-03-0 and that can be installed through Synaptic Package Manager. Does Solus have something like Synaptic?

antechdesigns
Posts: 257
Joined: Mon Jul 31, 2017 6:12 pm
Location: UK
Contact: Website

Re: Gimp doesn't start in Solus 3

Wed Aug 16, 2017 12:50 pm

chdslv wrote:
Wed Aug 16, 2017 12:37 pm
antechdesigns wrote:
Wed Aug 16, 2017 12:26 pm
Whats the output of:

Code: Select all

ls /usr/lib64/libgegl*
I am now in another Linux distro where Gimp is working. I looked in the Solus install from that distro. The following two files are there, libgegl-0.2.so.0 ( a symlink) and libgegl-0.2.so.0.199.1
Both have nothing inside them, 0 bytes.
Here is mine:

Code: Select all

/usr/lib64/libgegl-0.2.so.0  /usr/lib64/libgegl-0.2.so.0.199.1
file size is: 450.6kB
Did you do a clean install of solus 3 or did you upgrade?
Please Follow me on vidme: Solus Tutorials: https://vid.me/antechdesigns

Follow me on youtube: Solus Tutorials: https://www.youtube.com/channel/UCi4qFG ... YFA/videos

chdslv
Posts: 81
Joined: Fri Aug 08, 2014 5:54 am

Re: Gimp doesn't start in Solus 3

Wed Aug 16, 2017 1:10 pm

antechdesigns wrote:
Wed Aug 16, 2017 12:50 pm


Here is mine:

Code: Select all

/usr/lib64/libgegl-0.2.so.0  /usr/lib64/libgegl-0.2.so.0.199.1
file size is: 450.6kB
Did you do a clean install of solus 3 or did you upgrade?
A clean install of Solus 3.
Where can I download the missing?

Code: Select all

libgegl-0.2.so.0  and libgegl-0.2.so.0.199.1

antechdesigns
Posts: 257
Joined: Mon Jul 31, 2017 6:12 pm
Location: UK
Contact: Website

Re: Gimp doesn't start in Solus 3

Wed Aug 16, 2017 1:29 pm

Check if all these dependencies got installed:
  • babl
  • gegl
  • aalib
  • jasper
I just tested it on a clean install of solus 3 installed & ran without problems. Maybe something up with your iso?
Also I would wait for a developer to reply to see if he can shed some light on the problem.
Please Follow me on vidme: Solus Tutorials: https://vid.me/antechdesigns

Follow me on youtube: Solus Tutorials: https://www.youtube.com/channel/UCi4qFG ... YFA/videos

chdslv
Posts: 81
Joined: Fri Aug 08, 2014 5:54 am

Re: Gimp doesn't start in Solus 3

Wed Aug 16, 2017 1:49 pm

antechdesigns wrote:
Wed Aug 16, 2017 1:29 pm
Check if all these dependencies got installed:
  • babl
  • gegl
  • aalib
  • jasper
I just tested it on a clean install of solus 3 installed & ran without problems. Maybe something up with your iso?
Also I would wait for a developer to reply to see if he can shed some light on the problem.
If some such app/package is missing, from where and how to download them?
Sure, I'd wait for a developer to reply on the matter.

antechdesigns
Posts: 257
Joined: Mon Jul 31, 2017 6:12 pm
Location: UK
Contact: Website

Re: Gimp doesn't start in Solus 3

Wed Aug 16, 2017 1:53 pm

chdslv wrote:
Wed Aug 16, 2017 1:49 pm
antechdesigns wrote:
Wed Aug 16, 2017 1:29 pm
Check if all these dependencies got installed:
  • babl
  • gegl
  • aalib
  • jasper
I just tested it on a clean install of solus 3 installed & ran without problems. Maybe something up with your iso?
Also I would wait for a developer to reply to see if he can shed some light on the problem.
If some such app/package is missing, from where and how to download them?
Sure, I'd wait for a developer to reply on the matter.
Use the software center to check if they are installed. If they are installed then something else is amiss, which is why I mentioned a corrupt ISO
Use the search function in software center to check the dependencies I listed.
Please Follow me on vidme: Solus Tutorials: https://vid.me/antechdesigns

Follow me on youtube: Solus Tutorials: https://www.youtube.com/channel/UCi4qFG ... YFA/videos

User avatar
kyrios
Posts: 896
Joined: Thu Sep 22, 2016 4:20 pm

Re: Gimp doesn't start in Solus 3

Wed Aug 16, 2017 3:50 pm

chdslv wrote:
Wed Aug 16, 2017 12:00 pm
Gimp doesn't start in Solus 3
chdslv@chdslv ~ $ gimp
gimp: error while loading shared libraries: /usr/lib64/libgegl-0.2.so.0: file too short

I just installed gimp on a fresh solus 3 budgie and it works.
Try to force a reinstall of gegl as it seems to be the guilty guy:

Code: Select all

sudo eopkg it gegl --reinstall

Return to “Multimedia”