plumbumber
Posts: 3
Joined: Fri Nov 17, 2017 8:08 pm

Nvidia-settings multiple display settings lost at reboot fix

Sat Nov 18, 2017 1:34 pm

Hi,

I've had a lot of issues trying to get my nvidia settings to stuck at reboot. This is because the display settings from budgie overwrite the settings from nvidia. i don't know if this will help with other settings but it will help you to not have to rearrange your displays every time you reboot your system.

Its 4 simple steps.

1. arrange your displays in nvidia settings , i couldn't find mirroring in budgie display settings so i had to go this way.

2. open budgie display settings. they should match your nvidia settings at the moment but it wont stick after reboot.

3. change the refresh rate of 1 screen to a different value like 59 Hz. Apply settings, keep configuration.

4. change the Hz back to 60 Hz (or your refresh rate). Apply , keep configuration

This simple yet working fix helped me get rid of one of my most frustrating issue's with any linux distro, i have tried ALLOT of diffferent things like nvidia-settings --load-config-only at boot, adding 20-nvidia.conf to /etc/X11/xorg.conf.d/20.nvidia.conf ,... this is the only thing that works.

Hope this helps some of you :)

mfseeker
Posts: 1
Joined: Thu Jan 18, 2018 6:59 pm

Re: Nvidia-settings multiple display settings lost at reboot fix

Thu Jan 18, 2018 7:11 pm

Even though I am not using Solus (but rather Debian Stretch xfce lightdm), I post this here for those who may have friends suffering this problem using Nvidia-settings with a different distro. This fix works for my configuration. I have spent many hours wrestling with this problem. Your solution is the only one that has worked for me.

Why it works remains a mystery, but you know what they say about gift horses.

Thanks,

Stan

Return to “Tutorials”