selwynorren
Posts: 63
Joined: Sat Aug 06, 2016 1:30 am

installing Beersmith

Tue Dec 19, 2017 12:13 pm

Hey All,

I have installed beersmith2. However when I try and run it, I keep getting the following error:
beersmith2: error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory

I then created a symlink like this
sudo ln -s /usr/lib/libwebkitgtk-3.0.so /usr/lib/libwebkitgtk-1.0.so.0

however if I do that I get the following error:
(beersmith2:11510): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported

Can anyone offer advice on how to fix this?

sunnyflunk
Development Team
Posts: 2882
Joined: Sun Mar 13, 2016 11:35 pm

Re: installing Beersmith

Tue Dec 19, 2017 11:58 pm

selwynorren wrote:
Tue Dec 19, 2017 12:13 pm
Hey All,

I have installed beersmith2. However when I try and run it, I keep getting the following error:
beersmith2: error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory

I then created a symlink like this
sudo ln -s /usr/lib/libwebkitgtk-3.0.so /usr/lib/libwebkitgtk-1.0.so.0

however if I do that I get the following error:
(beersmith2:11510): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported

Can anyone offer advice on how to fix this?
A symlink won't work as they are completely incompatible. In fact, libwebkitgtk-3.0.so will be gone before long. I wouldn't recommend anyone touching libwebkitgtk-1.0 :shock:

selwynorren
Posts: 63
Joined: Sat Aug 06, 2016 1:30 am

Re: installing Beersmith

Wed Dec 20, 2017 10:03 am

Thanks, hopefully beersmith will then update their dependence soon enough

Return to “Tutorials”