userx
Posts: 31
Joined: Sat Jan 06, 2018 3:18 pm

No Vala compiler found but it is required.

Sat Jan 06, 2018 3:41 pm

I installed valadoc and libvala and vala and valadoc-devel and I am still getting that error.

I am trying to install pcmanfm the hard way, because that is the file manager I like the most that is not in your repo. So what to do to get the Vala compiler part working so I can move on with this?

User avatar
kyrios
Posts: 2073
Joined: Thu Sep 22, 2016 4:20 pm

Re: No Vala compiler found but it is required.

Sat Jan 06, 2018 11:14 pm

userx wrote:
Sat Jan 06, 2018 3:41 pm
I installed valadoc and libvala and vala and valadoc-devel and I am still getting that error.

I am trying to install pcmanfm the hard way, because that is the file manager I like the most that is not in your repo. So what to do to get the Vala compiler part working so I can move on with this?
The compiler is in the vala package in /bin/vala or /bin/valac
My guess is that you need libvala-devel

userx
Posts: 31
Joined: Sat Jan 06, 2018 3:18 pm

Re: No Vala compiler found but it is required.

Mon Jan 08, 2018 4:06 pm

let me go dig back into this issue to refresh my memory as to where I left off at, and check into your suggestion. Thanks.

Actually I think that may have been for WindowMaker that it was not being found. I was installing my wants onto Here and I do remember that WindowMaker too was giving me issues.

Return to “Tutorials”