MatthewBrock
Posts: 2
Joined: Thu Feb 15, 2018 3:17 pm

Can't Download NTP

Thu Feb 15, 2018 3:26 pm

I need to sync my clock with ntp, but I can't find the package on Solus. When I put timedatectl status into the terminal, it tells me

System clock synchronized: yes

systemd-timesyncd.service active: yes

I've disabled lightdm from systemctl so far, which seemed to help, but I still need to syns with ntp. Is there another way to sync?

User avatar
kyrios
Posts: 1922
Joined: Thu Sep 22, 2016 4:20 pm

Re: Can't Download NTP

Thu Feb 15, 2018 7:47 pm

MatthewBrock wrote:
Thu Feb 15, 2018 3:26 pm
I need to sync my clock with ntp, but I can't find the package on Solus. When I put timedatectl status into the terminal, it tells me

System clock synchronized: yes

systemd-timesyncd.service active: yes

I've disabled lightdm from systemctl so far, which seemed to help, but I still need to syns with ntp. Is there another way to sync?
Are you on the MATE edition ?
Perhaps this could help : https://dev.solus-project.com/T3836

MatthewBrock
Posts: 2
Joined: Thu Feb 15, 2018 3:17 pm

Re: Can't Download NTP

Thu Feb 15, 2018 8:15 pm

kyrios wrote:
Thu Feb 15, 2018 7:47 pm
MatthewBrock wrote:
Thu Feb 15, 2018 3:26 pm
I need to sync my clock with ntp, but I can't find the package on Solus. When I put timedatectl status into the terminal, it tells me

System clock synchronized: yes

systemd-timesyncd.service active: yes

I've disabled lightdm from systemctl so far, which seemed to help, but I still need to syns with ntp. Is there another way to sync?
Are you on the MATE edition ?
Perhaps this could help : https://dev.solus-project.com/T3836
I'm using budgie, and nothing happened when I changed the timesyncd.conf file. My main issue is that I don't have ntp installed, but it doesn't exist as a package.

User avatar
kyrios
Posts: 1922
Joined: Thu Sep 22, 2016 4:20 pm

Re: Can't Download NTP

Thu Feb 15, 2018 10:33 pm

MatthewBrock wrote:
Thu Feb 15, 2018 8:15 pm
I'm using budgie, and nothing happened when I changed the timesyncd.conf file. My main issue is that I don't have ntp installed, but it doesn't exist as a package.
You don't have to install a ntp package as this is managed by systemd. You may have to wait a few minutes after the service is started for the time to synchronize. For me it works fine:



● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2018-02-15 13:06:58 CET; 9h ago
Docs: man:systemd-timesyncd.service(8)
Main PID: 537 (systemd-timesyn)
Status: "Synchronized to time server 198.206.133.14:123 (2.debian.pool.ntp.org)."
Tasks: 2 (limit: 4915)
CGroup: /system.slice/systemd-timesyncd.service
└─537 /usr/lib/systemd/systemd-timesyncd

Return to “Tutorials”