User avatar
kz6fittycent
Posts: 1
Joined: Wed Mar 21, 2018 11:39 pm
Contact: Twitter

How to re-enable Bluetooth via systemd

Wed Mar 21, 2018 11:58 pm

After a recent update (21 March 2018), I noticed that my Bluetooth suddenly quit working. After several attempts to turn it on via Gnome's Control Center and even unplugging it and plugging it back in several times, I decided to take a look at rfkill, which I had to install via:

Code: Select all

sudo eopkg it rfkill
Oddly, rfkill was saying "all is well":

Code: Select all

rfkill list
4: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
This through me off a bit so I decided to dig a bit deeper and tried issuing the following command:

Code: Select all

bluetoothctl
which then hung at "# bluetoothd"

That indicated that perhaps I might be able to resolve the situation via "systemd"

So, I left "bluetoothctl" open so I could monitor things via the terminal (never trust the GUI!!) and opened another terminal window. I then issued the following commands:

Code: Select all

sudo systemctl stop bluetooth
sudo systemctl enable bluetooth
sudo systemctl start bluetooth
I watched the other terminal window running bluetoothctl and was happy to see that everything started working. I was even able to see the terminal output when I connected my BT headphones:

Code: Select all

[CHG] Device FC:A8:9A:55:71:77 Connected: yes
[Uproar Wireless]# 
I hope this helps someone else with a similar situation in the future!!

Word out.

-kz6fittycent

Return to “Tutorials”