Lampropeltis
Posts: 13
Joined: Tue Jul 18, 2017 7:12 am

Black screen after turning on the PC / all good after reset

Mon Feb 12, 2018 8:58 pm

I've just installed the Solus from scrap, version: 3.26.2 (on boot it says: 4.4.18-51). I've had to do full wipe for some (unimportant, and absolutely not retarded) reason. Previous setup worked like a charm.

It is the third try, the first one installed well, but while full system update (logged in after system install) screen went black, and there was nothing I could do - the OS didn't booted after that, stopping at the black screen and the white thing blinking... second try: after full update step by step (I've selected first the most important updates, rebooted, then the other two one after the other) system again didn't booted up.

I'm currently working on third try, and it looks like this:
- when I'm not using my PC I'm plugin it off from the power source (all the PC related stuff)
- after powering up the computer, when Solus should show me the login screen, its all black with the thing blinking on the upper left corner of the screen
- after reset it boots up like nothing have ever happen...

I have to do this every time, I start up my PC.

Previous setup worked well.

My setup: Intel Core i5-3570, as a GPU I'm using the integrated unit: Intel Ivybridge Desktop. 16GB of RAM, and old fashioned HDD.

My question: what the hell?? Why isn't Solus booting up in a normal way??

Lampropeltis
Posts: 13
Joined: Tue Jul 18, 2017 7:12 am

Re: Black screen after turning on the PC / all good after reset

Tue Feb 20, 2018 9:13 pm

Really?
Not one answer or question?

Not one developer is interested of this issue?

User avatar
kyrios
Posts: 1912
Joined: Thu Sep 22, 2016 4:20 pm

Re: Black screen after turning on the PC / all good after reset

Tue Feb 20, 2018 9:38 pm

Lampropeltis wrote:
Tue Feb 20, 2018 9:13 pm
Really?
Not one answer or question?

Not one developer is interested of this issue?
Look at the troubleshooting section of the help center.
https://solus-project.com/articles/troubleshooting/

KalinDimitrov
Posts: 90
Joined: Tue Dec 12, 2017 12:12 am
Location: Bulgaria/Sofia

Re: Black screen after turning on the PC / all good after reset

Wed Feb 21, 2018 1:12 pm

I will love to help you if I can but it is hard for me to understand what exactly happened.
My suggestion from what I have read is that something is messed with the update process.
In my opinion you always should update via terminal with sudo eopkg upgrade

Lampropeltis
Posts: 13
Joined: Tue Jul 18, 2017 7:12 am

Re: Black screen after turning on the PC / all good after reset

Wed Feb 21, 2018 6:55 pm

@KalinDimitrov

I did try to update via terminal, in this exact way:

1) Enter in login screen TTY (CTRL + ALT + F1)
2) sudo usysconf run -f
3) sudo eopkg rdb
4) sudo eopkg up

Let me write again, exactly what is going on here in points:

1) Install Solus3 from USB.
2) Boot and log in to the system.
3) Perform full system update (it takes a while...) / or in the next try (next full installation from zero) full system update in login screen via TTY (it takes a while...).
4) Reboot.
5) Black screen. Basically Solus "noped" on me...

This only happens now, with the latest release.
I was using Solus for about a year, when I killed it with my stupidity. Now I can't use it.

HDD is 100% clean, I did full mHDD test. 0 bad sectors. It is shiny clean.

Linux Mint is working like a charm. Antergos also works fine.

KalinDimitrov
Posts: 90
Joined: Tue Dec 12, 2017 12:12 am
Location: Bulgaria/Sofia

Re: Black screen after turning on the PC / all good after reset

Wed Feb 21, 2018 8:03 pm

Lampropeltis wrote:
Wed Feb 21, 2018 6:55 pm
@KalinDimitrov

I did try to update via terminal, in this exact way:

1) Enter in login screen TTY (CTRL + ALT + F1)
2) sudo usysconf run -f
3) sudo eopkg rdb
4) sudo eopkg up

Let me write again, exactly what is going on here in points:

1) Install Solus3 from USB.
2) Boot and log in to the system.
3) Perform full system update (it takes a while...) / or in the next try (next full installation from zero) full system update in login screen via TTY (it takes a while...).
4) Reboot.
5) Black screen. Basically Solus "noped" on me...

This only happens now, with the latest release.
I was using Solus for about a year, when I killed it with my stupidity. Now I can't use it.

HDD is 100% clean, I did full mHDD test. 0 bad sectors. It is shiny clean.

Linux Mint is working like a charm. Antergos also works fine.
Can you give some info about your hardware ?

Lampropeltis
Posts: 13
Joined: Tue Jul 18, 2017 7:12 am

Re: Black screen after turning on the PC / all good after reset

Wed Feb 21, 2018 8:30 pm

KalinDimitrov wrote:
Wed Feb 21, 2018 8:03 pm
Can you give some info about your hardware ?
Intel Core i5-3570, as a GPU I'm using the integrated unit: Intel Ivybridge Desktop. 16GB of RAM, and old fashioned HDD.


edit: all three editions of Solus are working in the same way. Install - update - die.

KalinDimitrov
Posts: 90
Joined: Tue Dec 12, 2017 12:12 am
Location: Bulgaria/Sofia

Re: Black screen after turning on the PC / all good after reset

Wed Feb 21, 2018 10:08 pm

Lampropeltis wrote:
Wed Feb 21, 2018 8:30 pm
KalinDimitrov wrote:
Wed Feb 21, 2018 8:03 pm
Can you give some info about your hardware ?
Intel Core i5-3570, as a GPU I'm using the integrated unit: Intel Ivybridge Desktop. 16GB of RAM, and old fashioned HDD.


edit: all three editions of Solus are working in the same way. Install - update - die.

I can only guess but maybe there is some issue with the kernel. By default you must use linux-current which after the last update is 4.15.3-53
Maybe there is some bug that make your system unbootable. Can you try to switch to linux-lts
Instructions should be here
https://solus-project.com/articles/trou ... gement/en/
And by black screen you mean that you don't have graphic environment but can use tty or just nothing ?

Lampropeltis
Posts: 13
Joined: Tue Jul 18, 2017 7:12 am

Re: Black screen after turning on the PC / all good after reset

Thu Feb 22, 2018 7:48 pm

KalinDimitrov wrote:
Wed Feb 21, 2018 10:08 pm
I can only guess but maybe there is some issue with the kernel. By default you must use linux-current which after the last update is 4.15.3-53
After the full update version of kernel was: 4.4.18-51.
KalinDimitrov wrote:
Wed Feb 21, 2018 10:08 pm
Maybe there is some bug that make your system unbootable. Can you try to switch to linux-lts
Its annoying and it takes time, but I'll give it a try. I really want to get back to Solus.
KalinDimitrov wrote:
Wed Feb 21, 2018 10:08 pm
And by black screen you mean that you don't have graphic environment but can use tty or just nothing ?
Black screen when the login screen should appear. Sometimes with the cursor blinking in the top left corner, sometimes without it.
Most of the time even TTY didn't worked. Just no reaction, I needed to reset PC.

KalinDimitrov
Posts: 90
Joined: Tue Dec 12, 2017 12:12 am
Location: Bulgaria/Sofia

Re: Black screen after turning on the PC / all good after reset

Thu Feb 22, 2018 9:56 pm

Lampropeltis wrote:
Thu Feb 22, 2018 7:48 pm
KalinDimitrov wrote:
Wed Feb 21, 2018 10:08 pm
I can only guess but maybe there is some issue with the kernel. By default you must use linux-current which after the last update is 4.15.3-53
After the full update version of kernel was: 4.4.18-51.
KalinDimitrov wrote:
Wed Feb 21, 2018 10:08 pm
Maybe there is some bug that make your system unbootable. Can you try to switch to linux-lts
Its annoying and it takes time, but I'll give it a try. I really want to get back to Solus.
KalinDimitrov wrote:
Wed Feb 21, 2018 10:08 pm
And by black screen you mean that you don't have graphic environment but can use tty or just nothing ?
Black screen when the login screen should appear. Sometimes with the cursor blinking in the top left corner, sometimes without it.
Most of the time even TTY didn't worked. Just no reaction, I needed to reset PC.
I fear that if kernel switching didn't work I can't help you. Your last resort is to ask someone probably developers on irc
https://solus-project.com/help-center/contact/

Return to “Other Questions”