User avatar
ovichiro
Posts: 17
Joined: Tue Jan 23, 2018 12:15 pm

Solus Budgie test - a bumpy first ride

Tue Jan 23, 2018 12:41 pm

Hi!
I've been using Ubuntu for about 9 years with a short period of openSuse during that time.
I saw some positive reviews of Solus last year so I finally installed Solus 3 Budgie a couple of weekends ago and tested it.
I'm mainly writing about stuff that did not work so well. A lot of things were great: gaming (gog and steam), music, video, snaps, wifi printing, general quality etc.
I'm hoping for some advice or feedback.
This will probably be a long post so I'll start with the short version.

Short version
----------------------

My main issues seem to have been related to the Intel graphics drivers. (Update: Or most likely `nouveau` as I later found.)
The live image freezes on reboot.
First install froze on updates, froze on pressing restart or shutdown buttons, wake-from-sleep did not work. With the nVidia drivers I don't have these problems.

Other small niggles are mostly related to Budgie: alt-tab behavior, theming, apps.

I installed it twice: first time on an external USB HDD, second time on an internal HDD. Both installs were EFI type with partitions, GPT set beforehand. The internal HDD also has Windows 10 on a different partition. Dual-booting works well through the EFI loader.

Long version follows...


System specs
-----------------------

Laptop - ASUS ROG GL552VW, Intel Skylake i7 6700HQ
RAM - 16GB
HDD - HGST 1TB in the DVD bay with an HDD caddy.
SSD - Sata 3 Samsung (not used for this test)
Dedicated graphics - nVidia GTX 960M


Main problems
---------------------------

1. Live image does not reboot

At first I tested Solus with the live image on a thumb drive.
Both Budgie and the Gnome Shell version froze when I tried to restart or shutdown.
It looked similar to this: https://imgur.com/a/rHpzC


2. Installing on an external USB hard drive

After the live test I installed Solus on an external HDD.

The install worked, I got the updates notification from the Software Center, I selected the Core and Security updates and hit update. At some point the update procedure froze.
Picture taken with the phone: https://imgur.com/a/efz1q
The bottom panel disappeared during the update.
I waited for a while, then forced a shutdown from the hardware button.
On second boot I got the same update notification, I tried again, this time with all updates selected (Gnome was about to update from 3.24 to 3.26). Froze again, waited a few minutes, shutdown, restart. On the third (or fourth) boot Gnome was at v 3.26 and updates were installed from what I remember.

Sleep did not work. Closed the lid, waited a bit, opened the lid. I think I ended up with a console prompt on which I couldn't type. I can't remember exactly.

Shutdown or restart did not work: https://imgur.com/a/rHpzC

I gave up on the external HDD install.


3. Installing on the internal HDD

Similar to the above.
Install worked, tried to install the updates (all of them), froze, left it there while I had breakfast, came back, forced a shutdown.
On restart updates were installed.
Shutdown and restart did not work, the DE just froze, same as the previous point.
It went to sleep, but never woke up: https://imgur.com/a/ENZZS
Keyboard lit up, screen was blank.

Question: On Ubuntu I used to REISUB out of situations like these instead of a hard shutdown. Is there a reason why this is disabled on Solus?

Proceeded to install the nVidia drivers.
At the restart prompt, when pressing the button, the DE froze: https://imgur.com/a/uWh5k
After the reboot I had a normal laptop. It shut down, slept, all looked fine. But this means I can't use the more power efficient Intel GPU.


Small problems
--------------------------

1. Budgie alt-tab

Open the Settings app and gedit to switch between them.

Go to `Universal Access - Repeat keys`: alt-tabbing (between Settings and gEdit) with the dialog open is weird. First time it works, subsequent tries put gEdit behind Settings instead of after it in the alt-tab order. Single alt-tabbing just stays on the Settings app.
Other weird things happen when having the `Repeat keys` dialog open and then just clicking on Firefox or some other app. Basically those other apps get placed between gEdit and Settings in the alt-tab order, even though my most recent clicked apps are gEdit and Settings.
Everything goes back to normal after closing the dialog.


2. Settings stuff

`Universal Access - Repeat keys - Speed slider` works the opposite of what I would expect, meaning currently the speed decreases as you pull it to the right. Probably a Gnome thing, but still. Also, I find `Universal Access` a very weird place to put stuff like this and then get absolutely no settings under the `Keyboard` section, save for shortcuts.

I searched forever for `Screen saver`/`Screen Lock`, only to find it in the Privacy category. The search functionality in Settings is almost useless; it only goes through the main categories.
The Budgie Menu search is better at finding sub-sections.
The old Settings layout was more sane, but Gnome is Gnome...


3. Theming

Tabs, like the ones in gedit, with the Adapta theme are huge.
Actually everything is very padded making menus very large in some cases. Just open LibreOffice Writer and things become ridiculous :)
This is solved with the Adapta-Eta theme.

Small and light shadows with a flat theme make for poor spatial separation of objects. I often confuse app windows because of this. Title bars suffer most from this when they overlap or touch since they are all almost black.
Some modal windows are frustrating to use because of poor separation also - white on white with black next to black and I can't tell which is which :) See the Disks utility with the SMART Data dialog for an example. Some fault lies with Gnome I think, although in Gnome Shell the main app window is shadowed when a dialog opens.

Another example I just stumbled upon: https://imgur.com/a/mpq6o
This looks like a fat title bar with text scattered around it.

Numix, Evopop and Paper are the only semi-viable alternatives, though each have wrinkles. Numix's shadows on Adapta would be a good start. And the Gnome shadow thing.


4. Firefox

Firefox freezes a few seconds after opening Google Maps and panning around. This used to happen in Ubuntu before the official release of v57, but doesn't anymore. I have no clue how to debug this.


5. Print screen button does not work in Budgie

I see there is a screenshot utility and found a blog post which said this is a conscious decision.
My problems:
- The `print screen` button cannot be bound to a custom shortcut for opening the utility.
- The keyboard in Settings lists shortcuts for taking screenshots that do not work, which is confusing.


6. Steam

`Settings - In-Home Streaming` does not fully display a check-box.


7. Sublime

Out of the box, sublime looks bad on a 1080p laptop monitor. Tabs and the side bar are tiny, especially the fonts.
They need to be adjusted via the default theme file (which has to be created).
I have no clue where this should be fixed.


Fixed in the meantime
--------------------------------------

These were things that got solved by some updates in the past week.

1. Trash bin bug

When mounting drives in Budgie, the drive's `.Trash` folder got interpreted as the current trash in the desktop.
The result was that I could not see my former trash if I had a drive mounted.


2. Log out, log back in

Had no sound.
Ctrl+Alt+right (switch desktop) also looked weird. The animation was not complete somehow.


3. Application install changed defaults

New application installs would change the default app for file types.
I tried with Pinta and Leafpad.

Installing Pinta would change the default image viewer to it.
Same thing happened with text when you installed Leafpad.
This was unexpected to me since I usually install apps for certain cases and would expect defaults to stay the same unless I explicitly change them.


Desired apps
------------------------

Kdiff3 - the most complete free diff and sync tool out there. Meld is way behind and has flaws.

Back-in-time - graphical snapshot backup. Will vote on the tracker.


Thank you and keep up the great work!
Last edited by ovichiro on Mon Jan 29, 2018 9:06 pm, edited 1 time in total.

brent
Posts: 222
Joined: Tue Apr 11, 2017 2:31 am
Location: desert usa

Re: Solus Budgie test - a bumpy first ride

Tue Jan 23, 2018 11:39 pm

This reply is regarding updates only.
All I could address is your #2, since I am running off a USB drive as well.
But any info I give you is moot because you had update success in the software center for your HDD install.
My advice is the same either way: install updates thru terminal (sudo eopkg up). I have had update problems in the SC before so I don't use it for updates anymore.
Besides, if there are conflicts or reasons for stalled/non-updates, all will be revealed in terminal.

There's also a terminal command (I forgot, sorry!) that checks package integrity with rebuild option.
Hope you get the rest answered, good luck.

User avatar
ovichiro
Posts: 17
Joined: Tue Jan 23, 2018 12:15 pm

Re: Solus Budgie test - a bumpy first ride

Wed Jan 24, 2018 10:11 am

brent wrote:
Tue Jan 23, 2018 11:39 pm
But any info I give you is moot because you had update success in the software center for your HDD install.
My advice is the same either way: install updates thru terminal (sudo eopkg up). I have had update problems in the SC before so I don't use it for updates anymore.
Thanks for the advice. I'll keep that in mind from now on.
I don't think it's moot. I finally had success because of the USB HDD experience.
To anybody else who might be reading - Aren't all Intel laptops affected by freeze on restart/shutdown?

User avatar
ovichiro
Posts: 17
Joined: Tue Jan 23, 2018 12:15 pm

Re: Solus Budgie test - a bumpy first ride

Fri Jan 26, 2018 10:40 pm

There's a bug report for the restart/shutdown issues: https://dev.solus-project.com/T4414
In short, `nouveau` may be to blame, so blacklist it. This works for me and I can use the Intel driver. Sleep also works fine.

Code: Select all

sudo mkdir /etc/modprobe.d
echo "blacklist nouveau" | sudo tee -a blacklist.conf

sunnyflunk
Development Team
Posts: 2750
Joined: Sun Mar 13, 2016 11:35 pm

Re: Solus Budgie test - a bumpy first ride

Mon Jan 29, 2018 2:32 am

ovichiro wrote:
Tue Jan 23, 2018 12:41 pm
The install worked, I got the updates notification from the Software Center, I selected the Core and Security updates and hit update. At some point the update procedure froze.
You will absolutely need to perform a full update after installing, otherwise I wouldn't expect it to work.

There is a major change in package updates so I would expect it to 'pause' rather than freeze well that happens

User avatar
ovichiro
Posts: 17
Joined: Tue Jan 23, 2018 12:15 pm

Re: Solus Budgie test - a bumpy first ride

Mon Jan 29, 2018 9:51 am

sunnyflunk wrote:
Mon Jan 29, 2018 2:32 am
You will absolutely need to perform a full update after installing, otherwise I wouldn't expect it to work.

There is a major change in package updates so I would expect it to 'pause' rather than freeze well that happens
The desktop became unusable, I couldn't do anything and the bottom panel disappeared. The same thing happened on my second install, when all updates were selected.
Also, after the Install and the updates and some reboots, I couldn't get to a `tty` with Ctrl+Alt+F1 - the desktop froze. Same thing happens with the live image.
I can get to a `tty` now after I have blacklisted the `nouveau` driver.

I'm almost convinced that all my issues under `Main problems` have something to do with the `nouveau` driver being active while using the Intel integrated graphics.

Related fix: viewtopic.php?f=14&t=11207&p=36160#p36160

Return to “Testing”