Page 2 of 3

Re: Important: Repo changes

Posted: Sat Jan 17, 2015 2:52 pm
by dragoneye
ikey wrote:Oh also let me know how the new kernel performs =) (tweaked)
Sure Ikey..always Thanks for your great work..! ;)

Re: Important: Repo changes

Posted: Sat Jan 17, 2015 2:56 pm
by ikey
My pleasure! Might be obvious but we're now in complete overdrive, if GitHub is anything to go by!

https://github.com/evolve-os/repository/commits/master

https://github.com/ikeydoherty?tab=activity

Re: Important: Repo changes

Posted: Sat Jan 17, 2015 4:52 pm
by dragoneye
Ikey all worked fine after uninstalling and installing nvidia driver..!

Re: Important: Repo changes

Posted: Mon Jan 19, 2015 5:59 pm
by GeneC
Hi Ikey... :)

Hmmm. No workie

Code: Select all

gene@evolve ~ 
$ sudo eopkg remove-repo EvolveOS
Password: 
Repo EvolveOS removed from system.
gene@evolve ~ 
$ sudo eopkg add-repo EvolveOS http://packages.evolve-os.com/main/eopkg-index.xml.xz
Repo EvolveOS added to system.
Updating repository: EvolveOS
eopkg-index.xml.xz.sha1sum     (40.0  B)100%    305.10 KB/s [00:00:00] [complete]
eopkg-index.xml.xz             (152.0 KB)100%    183.94 KB/s [00:00:00] [complete]
No signature found for http://packages.evolve-os.com/main/eopkg-index.xml.xz
Package database updated.
gene@evolve ~ 
$ sudo eopkg upgrade
Updating repositories
Updating repository: main
Program terminated.
Could not fetch destination file "http://packages.evolve-os.com/eopkg-index.xml.xz.sha1sum": [Errno 14] HTTP Error 404 : http://packages.evolve-os.com/eopkg-index.xml.xz.sha1sum 
Please use 'pisi help' for general help.

Code: Select all

gene@evolve ~ 
$ inxi -F
Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
System:    Host: evolve Kernel: 3.16.6 x86_64 (64 bit) Desktop: N/A Distro: EvolveOS Alpha 4 
Machine:   Mobo: ASUSTeK model: M4A88TD-M/USB3 v: Rev X.0x
           Bios: American Megatrends v: 1501 date: 08/09/2012
CPU:       Quad core AMD Phenom II X4 955 (-MCP-) cache: 2048 KB 
           Clock Speeds: 1: 2100 MHz 2: 800 MHz 3: 3200 MHz 4: 3200 MHz
Graphics:  Card: NVIDIA GF104 [GeForce GTX 460]
           Display Server: N/A drivers: nouveau (unloaded: fbdev,vesa) Resolution: 108x28
Audio:     Card-1 NVIDIA GF104 High Definition Audio Controller driver: snd_hda_intel 
           Card-2 Creative Labs CA0106 Soundblaster driver: snd_ca0106 
           Card-3 Advanced Micro Devices [AMD] ATI SBx00 Azalia (Intel HDA) driver: snd_hda_intel 
           Sound: Advanced Linux Sound Architecture v: k3.16.6
Network:   Card: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169
           IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: xxxxxxxxxxxxxxxx
Drives:    HDD Total Size: 250.1GB (1.4% used) ID-1: /dev/sda model: WDC_WD2500HHTZ size: 250.1GB
Partition: ID-1: / size: 29G used: 3.2G (12%) fs: ext4 dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 34.0C mobo: 33.0C gpu: 41.0 
           Fan Speeds (in rpm): cpu: 759 sys-1: 1599 
Info:      Processes: 168 Uptime: 3 min Memory: 705.4/12046.3MB Init: systemd 
           Client: Shell (bash) inxi: 2.1.28 
??????

Code: Select all

$ sudo pisi lr
main [active]
   http://packages.evolve-os.com/eopkg-index.xml.xz
EvolveOS [active]
   http://packages.evolve-os.com/main/eopkg-index.xml.xz

Re: Important: Repo changes

Posted: Mon Jan 19, 2015 8:02 pm
by ikey
Remove all repos but the /main/eopkg-index.xml.xz one, sorry bout that.

Re: Important: Repo changes

Posted: Mon Jan 19, 2015 9:49 pm
by GeneC
Yep, that worked for the repo.... :)

Code: Select all

sudo eopkg remove-repo  main 
Password: 
Repo main removed from system.
But,upgrade download was real slow (60-80 KB/s) and stalled at "kernel modules"

Code: Select all

gene@evolve ~ 
$ sudo eopkg upgrade
Updating repositories
Updating repository: EvolveOS
eopkg-index.xml.xz.sha1sum     (40.0  B)100%    831.68 KB/s [00:00:00] [complete]
EvolveOS repository information is up-to-date.
Safety switch forces the upgrade of following packages:
bash-completion  cpio  glibc  openssl  pisi  python  wget
The following packages will be upgraded:
bash-completion        budgie-desktop  cpio     firefox            glibc           glibc-devel
gnome-settings-daemon  gnome-terminal  kernel   kernel-libc-devel  kernel-modules  libgnutls  
libpeas                libsecret       libwnck  openssl            openssl-devel   pisi       
python                 thunderbird     wget     xorg-server      
Total size of package(s): 130.91 MB
You must restart your system for the updates in the following package(s) to take effect:
    - glibc
Do you want to continue? (yes/no)yes
Downloading 1 / 22
Package glibc found in repository EvolveOS
glibc-2.18-6-1-x86_64.eopkg    (21.4 MB)100%     67.31 KB/s [00:00:01] [complete]
Downloading 2 / 22
Package pisi found in repository EvolveOS
pisi-3.2-29-1-x86_64.eopkg     (312.0 KB)100%     79.63 KB/s [00:00:00] [complete]
[...]
Downloading 12 / 22
Package kernel-modules found in repository EvolveOS
kernel-modules-3.18.3-29-1-x86_64.eopkg (18.9 MB) 26%     59.53 KB/s [00:03:59]
I'll try again later... ;)

Re: Important: Repo changes

Posted: Mon Jan 19, 2015 9:57 pm
by ikey
Sorry for the slow speeds! I've been syncing a lot of new packages, and I have no idea how many people are testing the new unstable repo :D

Re: Important: Repo changes

Posted: Mon Jan 19, 2015 10:03 pm
by GeneC
Its going.....slow and timing out but third time is a charm.... ;)

Re: Important: Repo changes

Posted: Mon Jan 19, 2015 10:13 pm
by ikey
Yeah we may need to look into distributing the bandwidth better now. Didn't realise but the servers beginning to take quite a pounding lately.. o_O

Sign of success? Or a clog in the intertubez, I haz no idea !

Re: Important: Repo changes

Posted: Mon Jan 19, 2015 10:26 pm
by GeneC
That did it....

Shiny new kernel.... :D

Nice...

Code: Select all

gene@evolve ~ 
$ inxi -F
Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
System:    Host: evolve Kernel: 3.18.3 x86_64 (64 bit) Desktop: N/A Distro: EvolveOS Alpha 4 
Machine:   Mobo: ASUSTeK model: M4A88TD-M/USB3 v: Rev X.0x
           Bios: American Megatrends v: 1501 date: 08/09/2012
CPU:       Quad core AMD Phenom II X4 955 (-MCP-) cache: 2048 KB 
           Clock Speeds: 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz
Graphics:  Card: NVIDIA GF104 [GeForce GTX 460]
           Display Server: N/A drivers: nouveau (unloaded: fbdev,vesa) Resolution: 108x28
.............