jussery
Posts: 1
Joined: Mon Sep 04, 2017 4:48 am
Contact: Website

graphics crashes after updating solus in virtualbox guest

Sun Mar 04, 2018 8:09 am

Virtualbox 5.2.8
Virtualbox Extension pack: 5.2.8
Host: Windows 10
Guest: Solus Budgie 3
Kernel: 4.15.7-60

Solus installs well. After full upgrade and reboot, graphics crashes and screen is not usable. Remote Display on 127.0.0.2:3389 shows the same. I'm thinking this is isn't a virtualbox issue.

Has anyone experienced this yet? Is there a solution?
Thanks in advance.
James

Currently using Solus in VirtualBox v5.2.8

User avatar
kyrios
Posts: 1926
Joined: Thu Sep 22, 2016 4:20 pm

Re: graphics crashes after updating solus in virtualbox guest

Sun Mar 04, 2018 10:23 am

jussery wrote:
Sun Mar 04, 2018 8:09 am
Virtualbox 5.2.8
Virtualbox Extension pack: 5.2.8
Host: Windows 10
Guest: Solus Budgie 3
Kernel: 4.15.7-60

Solus installs well. After full upgrade and reboot, graphics crashes and screen is not usable. Remote Display on 127.0.0.2:3389 shows the same. I'm thinking this is isn't a virtualbox issue.

Has anyone experienced this yet? Is there a solution?
Thanks in advance.
I am using virtualbox 5.2.8 (Solus as host and guest) with the kernel 4.15.7 too and it's working.
Someone reported that the guest additions failed to build. Did it work for you ?

Does your screen looks like the one on this article ?

User avatar
downhill
Posts: 6
Joined: Sun Mar 25, 2018 9:29 am

Re: graphics crashes after updating solus in virtualbox guest

Sun Apr 15, 2018 6:54 am

kyrios wrote:
Sun Mar 04, 2018 10:23 am
Does your screen looks like the one on this article ?
Thanks for this. Using right-CTRL-F1 and then right-CTRL-F7 resolves the screen issue for me under VirtualBox 5.2.8. However, it would be nice to know why this is happening. It wasn't an issue on another machine that I'm running Solus 3 Budgie as a guest under VirtualBox.

User avatar
kyrios
Posts: 1926
Joined: Thu Sep 22, 2016 4:20 pm

Re: graphics crashes after updating solus in virtualbox guest

Sun Apr 15, 2018 10:13 am

downhill wrote:
Sun Apr 15, 2018 6:54 am
kyrios wrote:
Sun Mar 04, 2018 10:23 am
Does your screen looks like the one on this article ?
Thanks for this. Using right-CTRL-F1 and then right-CTRL-F7 resolves the screen issue for me under VirtualBox 5.2.8. However, it would be nice to know why this is happening. It wasn't an issue on another machine that I'm running Solus 3 Budgie as a guest under VirtualBox.
Haven't found a solution yet.
It might be caused by the fact that it loads xorg server before the video driver is loaded or because lightdm doesn't apply the udev rules or something like that...

Any help of this is welcome because I already spent hours on this with very few progress... :(

Return to “Installation”