userx
Posts: 31
Joined: Sat Jan 06, 2018 3:18 pm

Lazarus pkg requirments incomplete and out datated.

Mon Jan 08, 2018 3:55 pm

I do not know exactly where else to post this in your forum. It is not a bug per se' just a mishap in packaging some software and keeping it updated by whom ever does that.

FYI:

I just installed Lazarus and was actually pleased to see it in your repo, but an when I seen the version and what it didn't install. I knew I was in for problems.

it is version lazarus-1.6.4-4-1-x86_64.eopkg the pascal version is fpc-3.0.2-5-1-x86_64.eopkg , the incomplete part is that Lazarus requires the fpc-source code to be installed along with Lazarus and fpc in order for it to function properly.

Not having fpc-source included in the installing of the package as one of its dependence causes Lazarus to not function properly.
Lazarus
fpc
fpc-source

All need to be installed in order for Lazarus to function properly.

out of date:
Lazarus is now version 1.8.x whereas the installed version is 1.6.4x
FPC is outdated it is now up to ver 3.0.4x

Just a need to know message to whom ever takes care of that repo.

userx

sunnyflunk
Development Team
Posts: 2967
Joined: Sun Mar 13, 2016 11:35 pm

Re: Lazarus pkg requirments incomplete and out datated.

Wed Jan 10, 2018 11:32 pm

Package update requests need to go on https://dev.solus-project.com/ with the value add from updating (there's a new version isn't sufficient). i.e. new features/bugfixes.

Also see https://solus-project.com/articles/software/lazarus/en/

Return to “Development”