taserhamg
Posts: 11
Joined: Wed Sep 20, 2017 7:54 pm

wireless networks don't detect on network manager

Sat Dec 30, 2017 9:14 pm

Hi everyone

I installed recently solus budgie on my netbook, but in the moment of try conect to wifi, in the panel icon don't show me wireless conections and in configuration menu in the wireless section show a messenge tell me that no wireless adaptadors detects. Solus is update.

Netbook is a Acer Aspire One D255

I have a dual boot with Manjaro and in this wifi is fine.

i installed the drivers with doflick and rebooted many times. in this moment only conected with ethernet mode.

Thanks firstly by your time.

User avatar
KerfufflyKitty
Posts: 39
Joined: Sat Dec 16, 2017 11:56 pm

Re: wireless networks don't detect on network manager

Sat Dec 30, 2017 9:42 pm

Hello there! :)

Can you please post the output of:

Code: Select all

lspci | grep -i -e 'network' -e 'ethernet'

taserhamg
Posts: 11
Joined: Wed Sep 20, 2017 7:54 pm

Re: wireless networks don't detect on network manager

Sun Dec 31, 2017 6:55 am

run comand show me this

Code: Select all

$ lspci | grep -i -e 'network' -e 'ethernet'
01:00.0 Ethernet controller: Qualcomm Atheros AR8152 v1.1 Fast Ethernet (rev c1)
02:00.0 Network controller: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter (rev 01)

User avatar
KerfufflyKitty
Posts: 39
Joined: Sat Dec 16, 2017 11:56 pm

Re: wireless networks don't detect on network manager

Sun Dec 31, 2017 11:38 am

It does seem to detect the presence of your device at least, so that's good. :) Can you please give the output of the following commands:

Code: Select all

ifconfig -a
inxi -Nx
lsmod

taserhamg
Posts: 11
Joined: Wed Sep 20, 2017 7:54 pm

Re: wireless networks don't detect on network manager

Mon Jan 01, 2018 1:12 am

Sorry for the late answer. Here the ouput of the comands:

Code: Select all

 $ ifconfig -a
enp1s0    Link encap:Ethernet  HWaddr 88:AE:1D:6A:FF:6E
          inet addr:192.168.1.66  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:323316 errors:0 dropped:0 overruns:0 frame:0
          TX packets:187897 errors:0 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000
          RX bytes:429490405  TX bytes:43747110

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Bcast:0.0.0.0  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:166 errors:0 dropped:0 overruns:0 frame:0
          TX packets:166 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:12682  TX bytes:12682

Code: Select all

$ inxi -Nx
Network:   Card-1: Qualcomm Atheros AR8152 v1.1 Fast Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: 5000 bus-ID: 01:00.0
           Card-2: Broadcom Limited BCM4313 802.11bgn Wireless Network Adapter
           bus-ID: 02:00.0
 

Code: Select all

$ lsmod
Module                  Size  Used by
fuse                   83136  3
msr                     2604  0
joydev                 10388  0
uvcvideo               75477  0
videobuf2_vmalloc       4774  1 uvcvideo
iTCO_wdt                5988  0
videobuf2_memops        1609  1 videobuf2_vmalloc
videobuf2_v4l2         10611  1 uvcvideo
videobuf2_core         25182  2 uvcvideo,videobuf2_v4l2
videodev              136981  3 uvcvideo,videobuf2_core,videobuf2_v4l2
iTCO_vendor_support     2033  1 iTCO_wdt
media                  19830  2 uvcvideo,videodev
acer_wmi               11689  0
snd_hda_codec_realtek    59764  1
snd_hda_codec_generic    55608  1 snd_hda_codec_realtek
sparse_keymap           3154  1 acer_wmi
rfkill                 15460  4 acer_wmi
i915                 1167056  4
snd_hda_intel          24826  3
i2c_algo_bit            5392  1 i915
drm_kms_helper        103668  1 i915
psmouse               108144  0
lpc_ich                14688  0
coretemp                5852  0
snd_hda_codec          91048  3 snd_hda_intel,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           51159  4 snd_hda_intel,snd_hda_codec,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep               6058  1 snd_hda_codec
i2c_i801               13232  0
evdev                  12010  14
atl1c                  34391  0
syscopyarea             3198  1 drm_kms_helper
snd_pcm                82564  3 snd_hda_intel,snd_hda_codec,snd_hda_core
i2c_smbus               3361  1 i2c_i801
sysfillrect             3690  1 drm_kms_helper
thermal                10238  0
sysimgblt               2303  1 drm_kms_helper
fan                     4214  0
snd_timer              20829  1 snd_pcm
fb_sys_fops             1506  1 drm_kms_helper
drm                   276487  6 i915,drm_kms_helper
snd                    59129  13 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_timer,snd_hda_codec_generic,snd_hda_codec_realtek,snd_pcm
soundcore               5603  1 snd
acpi_cpufreq            7836  1
battery                 8481  0
wmi                     7316  1 acer_wmi
tpm_tis                 4946  0
ac                      3827  0
tpm_tis_core            7360  1 tpm_tis
video                  28894  2 acer_wmi,i915
shpchp                 24153  0
tpm                    30948  2 tpm_tis,tpm_tis_core
button                  6581  1 i915
sd_mod                 32943  4
serio_raw               4618  0
uhci_hcd               22572  0
ahci                   28061  3
libahci                21732  1 ahci
ehci_pci                3975  0
ehci_hcd               43476  1 ehci_pci
usbcore               172583  4 uvcvideo,ehci_hcd,uhci_hcd,ehci_pci
usb_common              2286  1 usbcore

User avatar
KerfufflyKitty
Posts: 39
Joined: Sat Dec 16, 2017 11:56 pm

Re: wireless networks don't detect on network manager

Mon Jan 01, 2018 11:28 am

taserhamg wrote:
Mon Jan 01, 2018 1:12 am
Sorry for the late answer.

Tell me about it, I posted last year!! (Sorry for my poor pre-coffee morning jokes... :lol:) So it seems the wireless driver isn't loaded. Could you try:

Code: Select all

sudo modprobe wl
If that comes back with modprobe: FATAL: Module wl not found in directory, then try:

Code: Select all

sudo eopkg it broadcom-sta`uname -r | tr '.' '-' | grep -o "\-current"`
Then try the modprobe command again. If it still fails after that, you're not the first who has run into that problem. That person's workaround involves creating two new modprobe configuration files to manually load the wl driver. Here is how you do it:

Code: Select all

sudo echo "install wl /sbin/modprobe cfg80211; /sbin/insmod /lib/modules/$(/bin/uname -r)/kernel/drivers/net/wireless/wl.ko" > /etc/modprobe.d/hackboot.conf
sudo echo "wl" > /etc/modules-load.d/wl.conf
After that, restart your computer and the wireless card should show up. This is just a workaround, modprobe should know where to look for wl itself, so maybe someone more knowledgeable than me can help with a final solution that won't need this workaround. :)

taserhamg
Posts: 11
Joined: Wed Sep 20, 2017 7:54 pm

Re: wireless networks don't detect on network manager

Mon Jan 01, 2018 7:04 pm

Hi there

well, after morning coffee and a dessert i try with these, but look me this:

Code: Select all

sudo echo "install wl /sbin/modprobe cfg80211; /sbin/insmod /lib/modules/$(/bin/uname -r)/kernel/drivers/net/wireless/wl.ko" > /etc/modprobe.d/hackboot.conf
bash: /etc/modprobe.d/hackboot.conf: Permiso denegado
the "hackboot.conf" file is created run the line? or is should be create manually? or what happen...

into the directory don't see nothing like a hackboot.conf file

i'm recovery after the new year and i'm so confused e.e

User avatar
KerfufflyKitty
Posts: 39
Joined: Sat Dec 16, 2017 11:56 pm

Re: wireless networks don't detect on network manager

Mon Jan 01, 2018 7:34 pm

taserhamg wrote:
Mon Jan 01, 2018 7:04 pm
Hi there

well, after morning coffee and a dessert i try with these, but look me this:

Code: Select all

sudo echo "install wl /sbin/modprobe cfg80211; /sbin/insmod /lib/modules/$(/bin/uname -r)/kernel/drivers/net/wireless/wl.ko" > /etc/modprobe.d/hackboot.conf
bash: /etc/modprobe.d/hackboot.conf: Permiso denegado
the "hackboot.conf" file is created run the line? or is should be create manually? or what happen...

into the directory don't see nothing like a hackboot.conf file

i'm recovery after the new year and i'm so confused e.e
Oh whoopsie, yeah it won't allow that! That was my fault, sorry! :oops: Try this (in your home dir or anywhere else you can write)

Code: Select all

sudo echo "install wl /sbin/modprobe cfg80211; /sbin/insmod /lib/modules/$(/bin/uname -r)/kernel/drivers/net/wireless/wl.ko" > hackboot.conf
sudo mv hackboot.conf /etc/modprobe.d/
Same for the other file. :D

taserhamg
Posts: 11
Joined: Wed Sep 20, 2017 7:54 pm

Re: wireless networks don't detect on network manager

Mon Jan 01, 2018 8:43 pm

well, runing the modprobe command finally works wireless conections

Image

only a question, if run with other kernel, this works same ? or have to set other configuration, i said for i have troubles with kernel 4.14 (tearing in qupzilla an freeze playing videos) but in kernel lts don't have

User avatar
KerfufflyKitty
Posts: 39
Joined: Sat Dec 16, 2017 11:56 pm

Re: wireless networks don't detect on network manager

Mon Jan 01, 2018 8:44 pm

I'm really happy to hear it works! :) It should work with all other kernels too, you should only have to do this again if you re-install Solus. Just make sure you have the LTS driver installed for your card also.

Return to “Hardware”