RankoKohime
Posts: 2
Joined: Sun Apr 02, 2017 8:23 pm

Forcing perf modes on Nvidia laptop

Sun Jan 21, 2018 8:59 am

I'm trying to force low perf mode when on battery on my non-Optimus Nvidia laptop.

I did this under Ubuntu Mate with success, (the GPU got locked into perf mode 0, and wouldn't clock above 607 MHz when on battery), but I neglected to save my xorg.conf when I loaded Solus, so I can't be sure whether I Googled the same line as before, or whether it's something that Solus is doing specifically.

Solus respects the resolution and refresh specified in /etc/X11/xorg.conf, but it appears to be totally ignoring this line:

Code: Select all

    Option         "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x1"
I've tried various combinations of all of the numbers that each variable can be, but without effect.

I don't see any entries in the Journal, and the only thing I see in /var/log/Xorg.0.log is this:

Code: Select all

[  5206.460] (**) NVIDIA(0): Option "MetaModes" "1920x1080_60 +0+0"
[  5206.460] (**) NVIDIA(0): Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x1"
with no errors that I can see related to it.

Anyone have any ideas, thoughts on what I might look at?

Return to “Hardware”