anonuser
Posts: 1
Joined: Wed Jan 24, 2018 12:02 am

No Wi-fi adapter found

Wed Jan 24, 2018 12:10 am

Hi everyone,

I'm running a fresh install of Solus 3. I ran the updates through the Software Center, and then installed drivers through DoFlicky. After rebooting, I am not able to see any wireless networks.
I also ran sudo eopkg up; sudo eopkg install broadcom-sta as recommended from another thread. This also did not solve the problem. The settings menu says that no Wi-fi adapter is found (https://i.imgur.com/l1b51B7.png)

Is there anything else I can try?

ModdeyBane
Posts: 6
Joined: Mon Jan 08, 2018 9:13 pm

Re: No Wi-fi adapter found

Tue Jan 30, 2018 8:46 pm

What kind of wifi hardware do you have? I had the same problem with my Broadcom chip, no wifi even after installing the driver, and what got it working was this:
KerfufflyKitty wrote:
Thu Jan 04, 2018 7:19 am

Code: Select all

cd
sudo echo "install wl /sbin/modprobe cfg80211; /sbin/insmod /lib/modules/\$(/bin/uname -r)/kernel/drivers/net/wireless/wl.ko" > hackboot.conf
sudo mv hackboot.conf /etc/modprobe.d/
sudo echo "wl" > wl.conf
sudo mv wl.conf /etc/modules-load.d/
Then restart the computer or run sudo modprobe wl. :)
My wifi worked flawlessly after that, so maybe if you have a Broadcom chip too it might work for you?

998ste
Posts: 3
Joined: Wed Mar 28, 2018 5:11 pm

Re: No Wi-fi adapter found

Wed Mar 28, 2018 5:38 pm

Hi !

I followed the above steps, but was unable to perform 'sudo modprobe wl'..

However, the few additional files placed in

Code: Select all

/lib/modules/4.14.18-51.current/kernel/drivers/net/wireless/broadcom/brcm80211/

allowed me to do:

Code: Select all


/lib/modules/4.14.18-51.current/kernel/drivers/net/wireless/broadcom/brcm80211/brcmsmac 

$ sudo modprobe brcmsmac


-- and --

Code: Select all


/lib/modules/4.14.18-51.current/kernel/drivers/net/wireless/broadcom/brcm80211/brcmutil  

$ sudo modprobe brcmutil

Unsure which line actually fixed it but now Broadcom Limited BCM43224 802.11a/b/g/n (IF: wlp1s0b1) gets detected again.

So thanks for pointing me in the right direction !

--
--

988ste

Return to “Hardware”