Posts: 2
Joined: Fri Jan 26, 2018 5:01 am
Location: Thrissur, Kerala
Contact: Google+ Twitter YouTube

MTK Devices and Mobiles - No Safely Remove Option

Fri Jan 26, 2018 5:17 am

I connected my 'Vivo Y51L' Phone to 'Solus Gnome' (latest) and then Right Clicked The MTK Device from 'Files', but I didn't see the normal 'Safely Remove Drive' Option. So I unmounted It and then removed it. But I still found that the device is still showed in 'Files' but no trace of it in 'Disks'. I tried it 8 times and still the MTKDevice is shown but New One gets added each time. I tried 'udisksctl' to 'power-off' the device but failed. They seem disappear only when I restart my PC.
I tied it with my 'Microsoft Nokia 215' (Really Old Phone No touch Non Android Phone) and with 'Moto E2' and 'Lenovo TAB 2 7 Essentials'.
Nokia 215 failed to eject and the others showed the above result.

Any idea on how to solve this?
Any Bug Fixes for this?

[See Attached Image]
Screenshot from 2018-01-26 09-20-32.png
Screenshot from 2018-01-26 09-20-32.png (201.42 KiB) Viewed 65 times

Return to “Hardware”