Page 1 of 1

dual monitors with dual GPUs

Posted: Sat Jan 27, 2018 9:18 pm
by stakoov
My current desktop setup is with 2 GPUs one GeForce GTS 8*(it's old but i use it for only for my second monitor) series and Intel HD 4* series. When i install Solus (in live cd also) it's work perfect. After update all thing and restart one of monitors stop work.

I try to save my xorg config before update and then use them in this case my second monitor stay black and mouse pointer is (X). In display manager i can see only first monitor. I think the problem is in the X.org 1.9.5, because i didn't see other display related updates.

Any idea how to fix this ?

Re: dual monitors with dual GPUs

Posted: Sun Jan 28, 2018 1:38 am
by stakoov
I can confirm the problem is from X.org 1.9.5. I didn't have a problem with 1.8.4. Now any ideas how to downgrade to older version?

Re: dual monitors with dual GPUs

Posted: Mon Jan 29, 2018 3:56 am
by sunnyflunk
Did you install the nvidia drivers? cause I think it may only work on the open drivers.

Re: dual monitors with dual GPUs

Posted: Mon Jan 29, 2018 10:12 pm
by stakoov
Yes i try both nvidia drivers and nouveau drivers but with nvidia drivers this GPU didn't work properly on any distro. With open source one it's work. And now it's work on Solus without problems but with X.org 1.8.4.

Re: dual monitors with dual GPUs

Posted: Tue Feb 06, 2018 6:43 am
by Dirty Spaceman
Just posting this to confirm that I am having the same problem. I had the same problem on KDE spin fedora 27 as well. It seems to be an xorg problem since this is happening regardless of whether or not I am using the proprietary NViDIA drivers. After updating from install, I can now only use one of my monitors. Both monitors show up if I each plug them into the same card.

For more information on my setup:
I have an AOC-831W plugged into a GTX 660 Ti and a Samsung Syncmaster plugged into a GTX 670. If there is any more information I can provide, I would be happy to.