Page 1 of 1

Failed to initialize nvidia module

Posted: Tue Jan 30, 2018 4:27 am
by jmayniac
I have an Optimus laptop and I frequently add/remove the nvidia-glx-driver-current to enable/disable the Nvidia 960m chip in my laptop. I updated today and I installed nvidia-glx-driver-current and it worked fine. I didn't need it anymore, so I uninstalled it. Later today, I tried to install again, but I just get the blinking black cursor screen. I see there is a new 00-ldm.conf file in /etc/X11/xorg.conf.d but not the /etc/X11/xorg.conf file. I assume this is by design. Besides updating today, I have made no other changes.

Xorg.0.log

https://pastebin.com/AtsZ387F

Re: Failed to initialize nvidia module

Posted: Tue Jan 30, 2018 8:36 am
by andiskufi
I have the same issue. Whenever I install the nvidia drivers I get the black screen. Anything changed and I can no longer use my nvidia card?

Re: Failed to initialize nvidia module

Posted: Thu Feb 01, 2018 10:39 pm
by bayo
Same on Plasma fresh install - and after nvidia-glx-driver i get black screen too.
On Budgie works fine - but haven't try to remove the driver and install it back.

Re: Failed to initialize nvidia module

Posted: Fri Feb 02, 2018 3:09 am
by kyrios
bayo wrote:
Thu Feb 01, 2018 10:39 pm
Same on Plasma fresh install - and after nvidia-glx-driver i get black screen too.
On Budgie works fine - but haven't try to remove the driver and install it back.
https://dev.solus-project.com/T5701#103215

Re: Failed to initialize nvidia module

Posted: Fri Feb 02, 2018 5:54 am
by bayo
kyrios wrote:
Fri Feb 02, 2018 3:09 am
bayo wrote:
Thu Feb 01, 2018 10:39 pm
Same on Plasma fresh install - and after nvidia-glx-driver i get black screen too.
On Budgie works fine - but haven't try to remove the driver and install it back.
https://dev.solus-project.com/T5701#103215
I guess i have to wait for a new ISO then or for an update...

Thanks!