ivorjk
Posts: 2
Joined: Sat Mar 03, 2018 12:57 am

Laggy, choppy vertical scrolling with Dell Inspiron 7559 - nVidia GeForce GTX 960M & Intel Graphics 530

Sat Mar 03, 2018 1:25 am

Hello,

I've installed Solus - fantastic OS, and I'd like to use it as a daily driver.

I have a Dell Inspiron laptop 7559 (i7), with combined nVidia and Intel graphics cards. Here is the strange behaviour I'm seeing from Solus:

1.
After a fresh install, and no updates installed and not updating the nVidia hardware drivers, graphics are fine. Vertical scrolling in apps (e.g. Firefox, Chrome) is smooth and stable. But the system CANNOT shut down - Reboot and Shutdown freeze the system. Same occurs if I run from the terminal (tried different shutdown commands), with root privileges etc.

2.
If I update the system with the desktop software manager after the install, and install the nVidia hardware drivers via the desktop app, Reboot and Shutdown work fine. However, graphics are buggy, vertical scrolling in apps (e.g. Firefox, Chrome) is laggy and choppy.

So the OS won't allow me to have both normal graphics, AND the ability to reboot/shutdown at the same time!

I know there are issues with nVidia drivers, and I believe by default the install uses nouveau, which results in smoother graphics for me. But when I revert back to nouveau, I have problem 1. above - can't shut down.

I've tried all the usual suggestions on this board and elsewhere online, including nouveau.modeset=0 kernel param, and toggling layers.acceleration.force-enabled in browsers. Makes no difference.

The laptop multi-boots windows 10 and Kubuntu 17.10 and they run perfectly. I know the nvidia drivers have caused similar issues in my Kubuntu install, but since I've removed them Kubuntu is smooth and shuts down as required.

Any suggestions would be appreciated, because I'd like to be able to recommend this brilliant OS...

(graphics card info from - lshw -c video on working Kubuntu install)

*-display UNCLAIMED
description: 3D controller
product: GM107M [GeForce GTX 960M]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:02:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: latency=0
resources: memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:df000000-df07ffff

*-display
description: VGA compatible controller
product: HD Graphics 530
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 06
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:318 memory:dd000000-ddffffff memory:b0000000-bfffffff ioport:f000(size=64) memory:c0000-dffff

CassBurn
Posts: 21
Joined: Fri Dec 08, 2017 10:45 pm

Re: Laggy, choppy vertical scrolling with Dell Inspiron 7559 - nVidia GeForce GTX 960M & Intel Graphics 530

Mon Mar 05, 2018 10:10 am

Could you prompt the result of:

Code: Select all

glxinfo
and:

Code: Select all

lspci | grep VGA


Otherwise you could try to check if nvidia-glx-driver-current is installed or uninstall nvidia driver and do the following:

Code: Select all

sudo eopkg up
sudo eopkg it nvidia-glx-driver
sudo eopkg it nvidia-glx-driver-current
But it would be better to check your system information.

Did you set the nomodeset option ?

ivorjk
Posts: 2
Joined: Sat Mar 03, 2018 12:57 am

[SOLVED] Re: Laggy, choppy vertical scrolling with Dell Inspiron 7559 - nVidia GeForce GTX 960M & Intel Graphics 530

Sun Mar 11, 2018 2:23 am

Thanks for your response!

Since my original post, I've fixed it. It seems these issues are very common with my configuration and multi-boot environments. I'm booting Solus, Windows 10, Kubuntu and Mint.

I previously tried the nomodeset parameter by itself but this did not fix it.

However, I've found the following post which has a solution:
https://ubuntuforums.org/showthread.php?t=2346719

Look at the last post from distance7000 dated Jan 8th 2017. This works. Since applying this fix, there have only been one or two restart delays, and these could be cleared with Ctrl+Alt+Del/Backspace.

I have added the following kernal parameter to Solus and Linux Mint:
acpi_osi=! acpi_backlight=native irqpoll nouveau.modeset=0 idle=nomwait

This fixed reboot and shutdown problems in both Solus and Linux Mint. It may be possible to tweak these parameters to improve the solution further, as I'm not sure all of them are required.

You can add the parameter in Grub Customizer for Mint, and it can be added in Solus with the following instructions:
viewtopic.php?t=9038

Return to “Hardware”