bluuuee
Posts: 2
Joined: Wed Mar 07, 2018 8:06 pm

EDIT: how to fix tearing /w nouveau OR make proprietary nvidia drivers more smooth like the nouveau drivers?

Wed Mar 07, 2018 8:22 pm

Hey guys,
first of all, @devs: I love you all. You did an amazing work and I'm pretty sure solus will become even more popular within the next years, so keep the work going on!

Alright, now to my problem. After a fresh install I updated everything (400) packages and installed the offical nvidia closed source drivers from doFlicky. They seem to work and the settings currently are this:
- Force Full Composition Pipeline is turned ON on both displays.
- Gsync is disabled (Only one monitor supports it)
- One Monitor set to 144hz, the other set to 60hz

When I turn off Full Composition Pipeline and turn ON GSync there's no tearing on my Gsync monitor but on the other one, so I turned it off and forced full comp. pipeline on both and just disabled gsync though.

Alright, Csgo seems to work with 400fps and theres no tearing so far (so I assume the drivers are working correctly), but on the desktop, or more specifically, in every browser I tried, the scrolling just feels so unresponsive, it's like when you scroll with 30fps on a 144hz monitor. I don't know how to explain this but since I come from windows 10 and used firefox there all the time, I never noticed such a "poor" performance. It's not the performance in general, everything is working great but as soon as I scroll, it feels completely different and slower/laggier than it should. I don't know if its related to gsync or do my dual monitor setup, but I could not find any fix though. This is pretty annoying though so If anyone knows fix, I would really appreciate it, this is the one thing which annoys me that hard.

Did I miss anything on any settings or is this just linux related and unfixable in that sense? :x

And yes, I set layers.acceleration.force-enabled to true, which stopped the tearing only in firefox, but it still feels laggy / choppy.
Last edited by bluuuee on Fri Apr 06, 2018 7:17 pm, edited 1 time in total.

bluuuee
Posts: 2
Joined: Wed Mar 07, 2018 8:06 pm

EDIT

Fri Apr 06, 2018 7:16 pm

-- PUSH --

Since no one answered, I was doing some tests was able to track down the current problem.
As far as I know, budgie uses mutter as compositor but I didn't find any option to enable v-sync globally. Any idea on this?

2 Monitors /w different refresh rates + nvidia graphics twinview are just buggy in linux (at least for me)

You simply can't connect a 144Hz 1920x1080 Monitor and a 60 Hz 1440x900 Monitor while using twinview. I tested both. Either with the nouveau drivers or with the proprietary driver. The monitor with the higher refresh rate always locks down to 60 Hz (at least it feels like 60, its definitely not 144 Hz EITHER IF xrandr says its 144 Hz). I mean in windows it works but in linux, I simply gave up on twinview w/ nvidia.

Alright, so I disconnected my 2nd monitor and only using one monitor, my 144 Hz monitor. 144 is working and feels very smooth, except for firefox. I tested the firefox version of solus and the nightly build so I don't thing it's a problem to firefox.

Here's whats happening:

With the nouveau drivers:
Wow, It's pretty much smooth as butter when scrolling in firefox. The same smoothness level like in windows 10. But then we have one problem. Tearing. I can't eliminate the tearing. It's slightly noticeable on a 144 Hz monitor, but it's there and kinda annoying.
The problem is, Option "GLXVBlank" "true" is enabled by default, but tearing is still there with the nouveau drivers. So there's no fix I guess. I don't know if it's a bug related to mutter or to the open-source nouveau drivers, maybe some of you know :>

Alright so I installed the offical nvidia drivers. Well, I enabled Force Full Composition Pipeline and obv set it to 144 Hz in the nvidia-settings as well.
Well, with these drivers in general, firefox scrolling is much more choppy and not smooth compared to the nouveau drivers. It's hard but when you scroll it's like duriing the scroll you get random "lags", which results in "choppy" feeling. So, whats the problem here?
In firefox -> about:config the setting layers.acceleration.force-enabled was always set to true /w both drivers.

So right now I'm running the proprietary driver because No tearing > fast smooth repsonsive scrolling + tearing.

So to summary:

Nouveau drivers - Amazing for desktop performance but tearing can't be eliminated, at least I did not find any solution.
Nvidia drivers - no tearing but scrolling (in firefox maybe in other apps too) feels choppy/slower than with the nouveau drivers.

If anyone knows a fix, I would be happy!

EDIT FROM 07.04.2018 - 01:35

Uninstalled the Nvidia prop drivers because I couldn't handle the "slowness" - so Im running the nouveau and as of now - the tearing issue seems gone for me, at least in firefox where it was visible for me. I don't know why it's now better but there was an update before like 2hours ago, but I don't know if its related to that. Rn, Im kinda happy.

EDIT FROM THE DAY AFTER:

YO with the nouveau, tearing still seems better but according to some sites I have micro stuttering so I don't know if there's a way to fix this.

But what I found out now, when using the prop drivers everything should works better with FullCompositionPipeline On (what I have) but vsync should be disabled. As far as I know vsync in mutter is enabled by default. If anyone knows how to disable it I would be happy.
cheers

Return to “Hardware”