User avatar
gmol1
Posts: 62
Joined: Fri Dec 04, 2015 12:33 am

[Solved] Razer Blade Stealth late 2016 "randomly" freezes

Fri Feb 17, 2017 12:28 am

Hi guys, I've been having this issue where the screen flickers and the OS freeze, also it happened several times when I was trying to install Solus, it took me around 5 attempts to be able to install it, it happened every single time I was going to choose the partitions however now it seems to happen randomly, any idea of what the issue might be?

This is how it looks
Image

UPDATE:
I've found a workaround. Run the following command:

Code: Select all

sudo sh -c "echo  'i8042.nokbd' > /etc/kernel/cmdline.d/20_keyboard_fix.conf"
sudo clr-boot-manager update
and reboot.
Last edited by gmol1 on Mon Dec 11, 2017 12:56 am, edited 3 times in total.

User avatar
gmol1
Posts: 62
Joined: Fri Dec 04, 2015 12:33 am

Re: Razer Blade Stealth late 2016 "randomly" freezes

Mon Feb 27, 2017 12:10 am

Ok so I was able to replicate the issue, it seems to happen only when i'm typing, specially when the caps lock is on. There's nothing in the logs so I still don't know what the issue might be.

User avatar
gmol1
Posts: 62
Joined: Fri Dec 04, 2015 12:33 am

Re: Razer Blade Stealth late 2016 "randomly" freezes

Sun Mar 05, 2017 6:52 am

UPDATE: I can now successfully reproduce the issue. When I turn on caps and off and press any key the OS will freeze, I've noticed that if caps lock is on and I lock my session, I can turn it off and the OS wont crash, anyways for now I've disabled the caps lock key. I'd appreciate some help. Thanks.

sunnyflunk
Development Team
Posts: 2890
Joined: Sun Mar 13, 2016 11:35 pm

Re: Razer Blade Stealth late 2016 "randomly" freezes

Sun Mar 05, 2017 11:04 pm

gmol1 wrote:
Sun Mar 05, 2017 6:52 am
UPDATE: I can now successfully reproduce the issue. When I turn on caps and off and press any key the OS will freeze, I've noticed that if caps lock is on and I lock my session, I can turn it off and the OS wont crash, anyways for now I've disabled the caps lock key. I'd appreciate some help. Thanks.
Would recommend making a task on https://dev.solus-project.com/

Has a lot more eyes looking at it and the only place people look when it comes to fixing bugs.

lethed
Posts: 21
Joined: Mon Oct 30, 2017 6:57 am

Re: Razer Blade Stealth late 2016 "randomly" freezes

Mon Oct 30, 2017 7:18 am

I can confirm the same negative behavior occurs with the RBS mid-2017 model. Very frustrating :x

Were you able to get your problem fixed? How's your machine now?

User avatar
gmol1
Posts: 62
Joined: Fri Dec 04, 2015 12:33 am

Re: Razer Blade Stealth late 2016 "randomly" freezes

Mon Oct 30, 2017 9:03 am

lethed wrote:
Mon Oct 30, 2017 7:18 am
I can confirm the same negative behavior occurs with the RBS mid-2017 model. Very frustrating :x

Were you able to get your problem fixed? How's your machine now?
I did found a workaround, I've updated the main post, please take a look at it for instructions.

lethed
Posts: 21
Joined: Mon Oct 30, 2017 6:57 am

Re: [Solved] Razer Blade Stealth late 2016 "randomly" freezes

Mon Oct 30, 2017 10:41 pm

I see. Can you briefly explain what that command means? Is it meant to disable the laptop's built-in keyboard during machine startup prior to reaching the login prompt?

lethed
Posts: 21
Joined: Mon Oct 30, 2017 6:57 am

Re: [Solved] Razer Blade Stealth late 2016 "randomly" freezes

Fri Nov 03, 2017 9:17 pm

I am glad your fix helped you. I implemented your fix a couple days ago on mine, rebooted and didn't experience any problem.

But it reoccurred yesterday morning. No idea what caused it.

I again rebooted, it hasn't happened again just yet.

Do you know a command to run to capture the system crash logs?

User avatar
gmol1
Posts: 62
Joined: Fri Dec 04, 2015 12:33 am

Re: [Solved] Razer Blade Stealth late 2016 "randomly" freezes

Mon Dec 11, 2017 12:59 am

lethed wrote:
Fri Nov 03, 2017 9:17 pm
I am glad your fix helped you. I implemented your fix a couple days ago on mine, rebooted and didn't experience any problem.

But it reoccurred yesterday morning. No idea what caused it.

I again rebooted, it hasn't happened again just yet.

Do you know a command to run to capture the system crash logs?
I'm sorry I forgot a step, i've updated the instructions.

Return to “Hardware”