User avatar
GreenMartian
Posts: 171
Joined: Tue Feb 14, 2017 12:10 pm
Location: Wisconsin, US

Solved: Sceptre/Meltdown + Intel Skylake CPU

Sat Apr 14, 2018 6:43 am

Guys,

Was running Solus just fine, until the most recent 4.15 kernel update.

After recently upgrading linux-current, my system CPU pegs high with cpu whine. A hard shutdown is required because of an endless software shutdown of a wall of endless running text.

This also occurs in the linux-lts kernel now as well.

Recently reading about the latest batch of Linux kernels with sceptre/meltdown fixes, and that Intel chips are currently being affected. https://www.theverge.com/2018/1/3/16844 ... dows-linux

With my Skylake hardware, this same update behavior has occured on Solus, Antergos, Manjaro and Ubuntu.

Am I stuck up a river without a paddle?

Thanks,
GM
Last edited by GreenMartian on Tue Apr 17, 2018 7:35 am, edited 1 time in total.

User avatar
kyrios
Posts: 1973
Joined: Thu Sep 22, 2016 4:20 pm

Re: Sceptre/Meltdown + Intel Skylake CPU

Sat Apr 14, 2018 8:46 am

GreenMartian wrote:
Sat Apr 14, 2018 6:43 am
Guys,

Was running Solus just fine, until the most recent 4.15 kernel update.

After recently upgrading linux-current, my system CPU pegs high with cpu whine. A hard shutdown is required because of an endless software shutdown of a wall of endless running text.

This also occurs in the linux-lts kernel now as well.

Recently reading about the latest batch of Linux kernels with sceptre/meltdown fixes, and that Intel chips are currently being affected. https://www.theverge.com/2018/1/3/16844 ... dows-linux

With my Skylake hardware, this same update behavior has occured on Solus, Antergos, Manjaro and Ubuntu.

Am I stuck up a river without a paddle?

Thanks,
GM
What is the recent 4.15 kernel update version ?
For your info, patches for these vulnerabilities are deployed since kernels 4.9.74 / 4.14.11 at the very beginning of January.
I have a kabylake CPU on my machine and I'm running kernel 4.15.17 and I don't have any shutdown issue.
It should be caused by something else.

User avatar
GreenMartian
Posts: 171
Joined: Tue Feb 14, 2017 12:10 pm
Location: Wisconsin, US

Re: Sceptre/Meltdown + Intel Skylake CPU

Sat Apr 14, 2018 10:35 am

Right, every kernel available in the software center = patched & installed as an update = bricked Solus. The very same results also with Antergos, Manjaro, Ubuntu. Systemd-journald consumes at least one cpu core mostly 100%. The journal log just continue endlessly with repetitive text.

As a test, I've installed non-systemd spins MX Linux and AntiX. Their kernels have already been patched as well. So, I tested two kernels in each disto, and have not experienced any of the above mentioned issues.

My guess is that there's something changed with systemd in the patched kernels that is not playing nicely with the Skylake hardware.

GMet

User avatar
ycrawler
Posts: 135
Joined: Thu Aug 10, 2017 8:23 pm

Re: Sceptre/Meltdown + Intel Skylake CPU

Sat Apr 14, 2018 10:43 am

my skylake behaves normally, 4.15.17

User avatar
GreenMartian
Posts: 171
Joined: Tue Feb 14, 2017 12:10 pm
Location: Wisconsin, US

Re: Sceptre/Meltdown + Intel Skylake CPU

Sat Apr 14, 2018 11:46 am

When was that kernel released?

User avatar
kyrios
Posts: 1973
Joined: Thu Sep 22, 2016 4:20 pm

Re: Sceptre/Meltdown + Intel Skylake CPU

Sat Apr 14, 2018 11:48 am

GreenMartian wrote:
Sat Apr 14, 2018 11:46 am
When was that kernel released?
yesterday

User avatar
ycrawler
Posts: 135
Joined: Thu Aug 10, 2017 8:23 pm

Re: Sceptre/Meltdown + Intel Skylake CPU

Sat Apr 14, 2018 11:57 am

for the record my skylake behaved perfectly with all previous kernels as well

User avatar
GreenMartian
Posts: 171
Joined: Tue Feb 14, 2017 12:10 pm
Location: Wisconsin, US

Re: Solved: Sceptre/Meltdown + Intel Skylake CPU

Tue Apr 17, 2018 7:39 am

Solved.

Pcie errors in systemd-journal and journalctl.

Looks like a hardware conflict with power management in the newly patched kernel.

Simply added the following to the kernel parameter line, and updated grub.

Code: Select all

pcie_aspm=off

Return to “Hardware”