Falco
Posts: 2
Joined: Tue May 15, 2018 4:19 am

Solus Installation Problem

Tue May 15, 2018 4:49 am

Hey all, hopefully soon to be a new Linux user here, am hoping someone could point me in the right direction?

I followed the installation manual on the site, copied the solus image onto the USB using Rufus (and I later used Etcher, also to no avail), plugged it into a newly built computer meant for Linux, but upon trying to boot after it shows the Solus screen saying "Automatic Boot in 5 seconds" I get the messages:

[sda] No Caching mode page found
[sda] Assuming drive cache: write through
kvm: disabled by bios
capa flags index 3 larger than...
DRM: Pointer to flat panel table...

Then I lose video.

Help a newbie out?

Falco
Posts: 2
Joined: Tue May 15, 2018 4:19 am

Re: Solus Installation Problem

Tue May 15, 2018 10:49 am

I was hoping to edit this post, but I figured out the first part. The video was merely coming from the HDMI port, and not the DVI port I was connected to, so I plugged in an HDMI monitor, and was able to get video.


However, after booting into Solus on the USB, I ran into another problem. I installed Solus to my NVME m.2 drive, then rebooted. Upon reboot, I get a black screen that says: "No such device", and gives me a prompt that says "grub rescue".

Any idea how to get passed this? I feel like I'm sooo close to getting Solus installed now.

WonderingDane
Posts: 67
Joined: Wed Sep 02, 2015 4:02 pm
Location: Denmark
Contact: Website

Re: Solus Installation Problem

Tue May 15, 2018 7:30 pm

Do you install with UEFI?
Image

dschinn1001
Posts: 107
Joined: Mon Mar 20, 2017 5:31 pm

Re: Solus Installation Problem

Sun May 20, 2018 6:44 pm

Heeey Ho Heee Falco,

Go into BIOS-settings of your machine, when booting your machine with pressing key "F2".

Disable UEFI- mode and then
Enable Legacy-mode.

Then you are free to install Linux.

Behave ... ! - ... then solus works.

Robert45
Posts: 9
Joined: Thu Jan 19, 2017 9:20 am

Re: Solus Installation Problem

Thu May 24, 2018 11:15 am

That is so strange. I had to do the opposite on my Asus mobo. I had to enable UEFI for all OS then boot the installation disk on the UEFI option. Apart from Linux Mint and Arch other OS like Solus, Manjaro etc would not boot. I learn this from the TrueOS forum what having a look at it. It specifically referred to Asus mobos.
To be honest I do not know what mode Solus is booting all I know it is so quick. After POST the login screen is there.
If it is worth it I can post exactly the settings and the mobo I think it is a Z-87 but could be wrong. Once the setting is applied to the BIOS I can boot any installation I have tried.
Robert...

Return to “Installation”