SOLUS_INVICTUS
Posts: 25
Joined: Sun Jun 10, 2018 2:05 pm

Sound only on HDMI ports (Transformer Book T100TA)

Sun Jun 10, 2018 6:14 pm

Hello,

I've just tried and installed immediatly Solus on my Transformer Book T100TA :
Impressive ! I already installing Solus on other Laptops !
Absolutly statisfied ... Except some issues

No Sound No Brightness No wifi No Bluetooth for the moment ...

STEP 01 The sound
No Sound :
Solus with Gnome seems not detecting any sound hardware ...
I've installed budgie* to see if it would dectect something,
( * sudo eopkg install -c desktop.budgie )

=> Budgie indicate 2 HDMI ports on Settings/Sound
I've connected an HDMI Screen and tried the 2 ports :

I've a perfect sound on the HDMI display (with VLC or MPV, Budgie & Gnome) when I select the following port :
HDMI / DisplayPort - Atom Processeur Z36xxx/Z37xxx Series Graphics & Display
What to do to be able to select the internal sound Card ?
  • Infos:
    Solus : 3.9999
    GNOME : 3.28.2 (+ Budgie )
    MEMORY : 3.7 GiB
    PROCESSOR : Intel® Atom™ CPU Z3795 @ 1.60GHz × 4
    GRAPHICS : Intel® Bay Trail
    OS TYPE : 64-bit
    DISK : 56.8 GB
    (+ 64 Go SDCARD)
Thanks for your help and for that amazing distro !
Best regards
Last edited by SOLUS_INVICTUS on Mon Jun 18, 2018 10:30 pm, edited 2 times in total.

dschinn1001
Posts: 144
Joined: Mon Mar 20, 2017 5:31 pm

Re: SOUND ONLY ON HDMI PORTS (Transformer Book T100TA)

Tue Jun 12, 2018 5:12 pm

This was issue too in Ubuntu Forum.
In Ubuntu it then helped to install music packages
rhythmbox and amarok.

(I am deaf and cannot check any Sound.)

I dont know which music packages are available in solus.

It could help with:

> sudo eopkg install amarok rhythmbox

Because in packages are additional drivers.

Then sound should be there.

SOLUS_INVICTUS
Posts: 25
Joined: Sun Jun 10, 2018 2:05 pm

Re: SOUND ONLY ON HDMI PORTS (Transformer Book T100TA)

Tue Jun 12, 2018 8:26 pm

Thanks a lot for your reply : It is nice to see that it is an known problem ! :)
I tried, But...

For rhythmbox :
~ $ sudo eopkg install rhythmbox
The following package(s) are already installed and are not going to be installed again:
rhythmbox

No packages to install.
~ $


For amarok :
~ $ sudo eopkg install amarok
System error. Program terminated.
Repo item amarok not found

Please use 'eopkg help' for general help.
Use --debug to see a traceback.
~ $


Best regards

dschinn1001
Posts: 144
Joined: Mon Mar 20, 2017 5:31 pm

Re: SOUND ONLY ON HDMI PORTS (Transformer Book T100TA)

Wed Jun 13, 2018 4:43 pm

Then try else music packages :

First try this:

> sudo eopkg it - - reinstall rhythmbox

Then you could try this:

> sudo eopkg install sayonara

or:

> sudo eopkg install clementine

There are more music players listed here:

https://www.google.de/amp/s/www.tecmint ... ayers/amp/

Good luck.

SOLUS_INVICTUS
Posts: 25
Joined: Sun Jun 10, 2018 2:05 pm

Re: Sound only on HDMI ports (Transformer Book T100TA)

Thu Jul 19, 2018 2:10 pm

Hello,

The soung Issue is a direct consequence of the Update of Solus :
After making some test and reinstalling Solus many times, I found that :

Before Update :
The OS detects correctly the Analog port
  • HDMI / DisplayPort - Atom Processor Z36xxx/Z37xxx Series Graphics & Display.
  • Analog Output - Atom Processor Z36xxx/Z37xxx Series Graphics & Display
After Update :
The OS detects removes the Analog port which is replaced by a second HDMI port !
The Analog Output - Atom Processor Z36xxx/Z37xxx Series Graphics & Display port is no more present , that is why only HDMI ports can provide sound services...

Best regards

Hardware Menu :
https://drive.google.com/file/d/1c7KeAU ... sp=sharing

Raven menu :
https://drive.google.com/file/d/1ecFIjR ... sp=sharing

Return to “Installation”